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Small Internetworks

Introduction

In this lesson, you will see how Modeler can do 
organizational scaling to solve a typical “what if” 
problem. You will learn how to use Modeler features to 
build and analyze network models. This lesson 
focuses on the use of the Project Editor, and how it will 
be used with the Node and Process editors in later 
lessons. In this lesson, you will

• Build a network quickly

• Collect statistics about network performance

• Analyze these statistics

In this lesson, you use the Project Editor to build a 
topology of a small internetwork, choose statistics to 
collect, run a simulation, and analyze the results.
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Introduction

In this lesson, you plan for the expansion of a small 
company’s intranet. Currently, the company has a star 
topology network on the first floor of its office building 
and plans to add an additional star topology network 
on another floor. You will build and test this “what-if” 
scenario to ensure that the load added by the second 
network will not cause the network to fail.

The Final Network

First floor

Planned expansion
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Getting Started

Getting Started

When creating a new network model, you must first 
create a new project and scenario. A project is a 
group of related scenarios that each explore a different 
aspect of the network. Projects can contain multiple 
scenarios.

After you create a new project, you use the Startup 
Wizard to set up a new scenario. The options in the 
Wizard let you

• Define the initial topology of the network

• Define the scale and size of the network

• Select a background map for the network

• Associate an object palette with the scenario

Startup Wizard automatically appears each time you 
create a new project. The Startup Wizard allows you to 
define certain aspects of the network environment.
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Getting Started

To use the Startup Wizard to set up a new scenario, do 
the following:

1 If Modeler is not already running, start it.

2 Select File > New...

3 Select Project from the pull-down menu and click 
OK.

4 Name the project and scenario, as follows:

4.1 Name the project <initials>_Sm_Int 

Include your initials in the project name to 
distinguish it from other versions of this 
project.

4.2 Name the scenario first_floor.

4.3 Click OK.

➥ The Startup Wizard opens.

5 Enter the values shown in the following table in 
the dialog boxes of the Startup Wizard:
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Getting Started

Values to Enter in the Startup Wizard

➥ A workspace of the size you specified is 
created. The object palette you specified opens 
in a separate window.

Dialog Box Name Value

1. Initial Topology Select the default value: 
Create empty scenario.

2. Choose Network Scale Select Office. Check the 
Use metric units box.

3. Specify Size Select the default size: 
100 m x 100 m

4. Select Technologies Include the Sm_Int_Model_List 
model family.

5. Review Check values, then click Finish.
5



Creating the Network

Creating the Network

Network models are created in the Project Editor using 
nodes and links from the object palette. 

Node - A representation of a real-world network object 
that can transmit and receive information.

Nodes

Link - A communication medium that connects nodes 
to one another. Links can represent electrical or fiber 
optic cables.

A Link

These objects are found in the object palette, a dialog 
box that contains graphical representations of node 
and link models.

If it is still open, close the object palette.
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Creating the Network

You can use any of three methods to create a network 
topology, or a combination of all three. One method is 
to import the topology (discussed in a later lesson). 
Another is to place individual nodes from the object 
palette into the workspace. The third method is to use 
Rapid Configuration.

Rapid Configuration creates a network in one action 
after you select a network configuration, the types of 
nodes within the network, and the types of links that 
connect the nodes.

To create the first-floor network using Rapid 
Configuration:

1 Select Topology > Rapid Configuration.

2 Select Star from the drop-down menu of available 
configurations, then click OK...

Available Configurations Pop-up Menu
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Creating the Network

Specify the node models and link models in the 
network. Models follow this naming scheme:

<protocol1>_..._<protocoln>_<function>_<mod>

where:

• <protocol> specifies the specific protocol(s) 
supported by the model

• <function> is an abbreviation of the general 
function of the model

• <mod> indicates the level of derivation of the 
model

For example: 

ethernet2_bridge_int

specifies the intermediate (int) derivation of a 2-port 
Ethernet (ethernet2) bridge (bridge).

Vendor models have an additional prefix that specifies 
the vendor and the vendor product number for that 
particular network object.
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Creating the Network

For example, the 3Com switch used in this lesson is 
named:

 3C_SSII_1100_3300_4s_ae52_e48_ge3

This node is a stack of two 3Com SuperStack II 1100 
and two Superstack II 3300 chassis 
(3C_SSII_1100_3300) with four slots (4s), 52 
auto-sensing Ethernet ports (ae52), 48 Ethernet ports 
(e48), and 3 Gigabit Ethernet ports (ge3).

To specify the nodes and links to use to build the 
network:

1 Set the Center Node Model to 
3C_SSII_1100_3300_4s_ae52_e48_ge3. This is 
a 3Com switch.

2 Set the Periphery Node Model to 
Sm_Int_wkstn, and change the Number of 
periphery nodes to 30. This provides 30 Ethernet 
workstations as the peripheral nodes.

3 Set the Link Model to 10BaseT.
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Creating the Network

Specify where the new network will be placed:

1 Set the X center and Y center to 25.

2 Set the Radius to 20.

Rapid Configuration Dialog Box

3 Click OK.

➥ The network is drawn in the Project Editor:
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Creating the Network

The First Floor Network

Now that the general network topology has been built, 
you need to add a server. You will use the second 
method of creating network objects: dragging them 
from the object palette into the workspace.

1 If it is not already open, open the 
object palette by clicking on the 
Object Palette toolbar button.

2 Find the Sm_Int_server object in the palette and 
drag it into the workspace. 

You will not find this exact server model on other 
object palettes because we created it with the 
correct configuration for this tutorial.
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Creating the Network

By default, you can create additional instances of 
the same object by left-clicking after the initial 
“drag-and-drop” from the palette.

3 Because you do not need additional copies of this 
model, right-click to turn off node creation.
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Creating the Network

You also need to connect the server to the star 
network.

1 Find the 10BaseT link object in the palette and 
click on it.

2 Click on the server object, then click on the switch 
object in the center of the star.

➥  A link is drawn, connecting the two objects.

3 Right-click to turn off link creation.

Finally, you need to add configuration objects to 
specify the application traffic that will exist on the 
network. Configuring the application definition and 
profile definition objects can be complicated, so you do 
not have to do these tasks right now. For this tutorial, 
we included, on the object palette:

• an application definition object with the default 
configurations of the standard applications, and 

• a profile definition object with a profile that models 
light database access
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Creating the Network

You need only drag the objects into your network. 
Doing so means that the traffic caused by workstations 
accessing a database at a low rate will be modeled.

1 Find the Sm_Application_Config object in the 
palette and drag it into the workspace

2 Right-click to turn off object creation.

3 Find the Sm_Profile_Config object in the palette, 
drag it into the workspace, and right-click.

4 Close the object palette.
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Creating the Network

The network is now built and should look similar to the 
following figure.

The Finished First Floor Network

You are now ready to begin collecting statistics.
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Creating the Network

However, first let’s explore the Node and Process 
Editors.

The Node and Process Editors are integral to the 
OPNET workflow. The Node Editor is used to create 
node models that describe the internal flow of data 
within a network object. The Process Editor is used to 
create process models that describe the behavioral 
logic of a module in a node model.

Every network object (except links) has an underlying 
node model that specifies the internal flow of 
information in the object. Node models are made up of 
one or more modules connected by packet streams 
or statistic wires. Node modules in turn contain 
process models. A process model is represented by a 
state transition diagram (STD) that describes the 
behavior of a node module in terms of states and 
transitions. 
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Creating the Network

Let’s explore the node model that controls the server in 
the first floor network:

1 Double-click on node_31 (the 
Server object) in the Project Editor. 

➥ The Node Editor opens as a new 
window within Modeler.

The following figure shows the node 
model within the Ethernet Server network object. The 
node model is made up of several different types of 
modules which are described in the M/M/1 tutorial. 
Packet streams and statistic wires connect the 
modules.
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Creating the Network

Ethernet Server Node Model

During a simulation, packets sent from a client 
machine are received by the hub receiver object 
(hub_rx_0_0) and processed up the protocol stack to 
the application module. After processing, they are sent 
down the stack to the transmitter (hub_tx_0_0), then 
back to the client machine.

packet streams

statistic wire

modules
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Creating the Network

Packet Processing by the Node Model

Next, let’s look at the process model that defines the 
behavior of the tpal module. To view the process 
model:

1 Double-click on the tpal module in the 
Node Editor.

➥ The Process Model Editor opens in 
a new window.

After processing, 
packets are sent by the 
hub transmitter object

Packets are received by the hub 
receiver object
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Creating the Network

Example Process Model

2 Note the red and green states (these will be 
discussed in greater detail in the Basic Processes 
lesson) and the solid and dotted lines indicating 
transitions between the states.

Each state in the process model contains an 
enter executive and an exit executive. Enter 
executives are executed when a process enters a 
state. Exit executives are executed when the 
process leaves the state. Operations performed in 
the state are described in C or C++. 

3 Open an enter exec by double-clicking on the top 
half of the init state.

transitions

states
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Creating the Network

4 Open an exit exec by double-clicking on the 
bottom half of the state.

Opening the Enter Exec or Exit Exec of a State

5 Close both exec windows.

States are connected via transitions. Transitions 
can be either conditional (that is, they have a 
logical test that must be true before the transition 
occurs) or unconditional (no logical test). 

The following figure shows a conditional transition 
(the dotted line) from the wait state to the open 
state. The condition OPEN must be true before 

Click in the top 
half of the 
state to open 
an enter exec

Click in the 
bottom half to 
open an exit 
exec
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Creating the Network

the transition can occur. However, the transition 
from open to wait (solid line) is unconditional, 
and will occur whenever the code in the open 
state has finished execution.

Conditional and Unconditional Transitions

Later lessons explore these editors in greater 
depth. 

6 Close the Node and Process editors. If prompted, 
do not save changes.
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Collecting Statistics

Collecting Statistics

You can collect statistics from individual nodes in your 
network (object statistics) or from the entire network 
(global statistics).

Now that you have created the network, you should 
decide which statistics you need to collect to answer 
the questions presented earlier in this lesson:

• Will the server be able to handle the additional 
load of the second network?

• Will the total delay across the network be 
acceptable once the second network is installed?

To answer these questions, you need a snapshot of 
current performance for comparison. To get this 
baseline, you will collect one object statistic, Server 
Load, and one global statistic, Ethernet Delay.
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Collecting Statistics

Server load is a key statistic that reflects the 
performance of the entire network. To collect statistics 
related to the server’s load, do the following steps: 

1 Right-click on the server node (node_31) and 
select Choose Individual DES Statistics from 
the server’s Object pop-up menu.

➥ The Choose Results dialog box for node_31 
appears.

The Choose Results dialog box hierarchically 
organizes the statistics you may collect. To collect 
the Ethernet load on the server:

2 Expand the treeview for Ethernet in the 
Choose Results dialog box to see the Ethernet 
statistic hierarchy.
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Collecting Statistics

Choose Results Dialog Box

3 Click the checkbox next to Load (bits/sec) to 
enable collection for that statistic.

4 Click OK to close the dialog box.
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Collecting Statistics

Global statistics can be used to gather information 
about the network as a whole. For example, you can 
find out the delay for the entire network by collecting 
the global Delay statistic:

1 Right-click in the workspace (but not on an object) 
and select Choose Individual DES Statistics 
from the Workspace pop-up menu.

Global Statistic Chosen
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Collecting Statistics

2 Expand the Global Statistics hierarchy.

3 Expand the Ethernet hierarchy.

4 Click the checkbox next to Delay (sec) to enable 
data collection.

5 Click OK to close the Choose Results dialog box.

It is good to get into the habit of saving your project 
every so often. To save the project:

1 Choose File > Save, then click Save (the project 
already has a name, so you don’t need to rename 
it).

Now that you have specified the statistics to collect 
and saved the project, you are almost ready to run 
your simulation. 

First, though, verify that your repositories preference 
is set appropriately.

1 Choose Edit > Preferences.

2 Type repositories in the Find field and click on 
the Find button.
27



Collecting Statistics

3 If the value for repositories is not stdmod, click 
on the field.

4 When the repositories dialog box appears, click 
the Insert button then enter stdmod in the dialog 
box.

5 Click OK to close the repositories and 
Preferences dialog boxes.

To run a simulation:

1 Select DES > Configure/Run Discrete Event 
Simulation….

You can also open the Configure Discrete 
Event Simulation dialog box by clicking 
on the Configure/Run Discrete Event 
Simulation (DES) toolbar button.

2 Type 0.5 in the Duration: field to simulate 
one-half hour of network activity.

Configure Discrete Event Simulation Dialog Box
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Collecting Statistics

3 Set the Simulation Kernel to optimized.

You can use one of two types of kernels to run 
your simulation. The development kernel collects 
simulation data you can use to debug your 
models, but the optimized kernel runs faster.

4 Click the Run button to begin the simulation.

While the simulation runs, a dialog box appears 
showing the simulation’s progress.

Simulation Sequence Dialog Box

The dialog box above shows that, in 2 seconds of 
elapsed (actual) time, Modeler has simulated 4 
minutes and 29 seconds of network time. The 

Elapsed Time: Number of seconds the simulation has run

Simulated Time: Minutes of network time
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Collecting Statistics

entire simulation should take less than one minute 
to complete—the elapsed time varies according 
to the speed of your computer.

5 When the simulation finishes, the contents of the 
Messages tab appears. Click the Close button in 
the Simulation Sequence dialog box.

6 If your simulation does not complete, if no results 
were collected, or if the results vary significantly 
from those shown, you will have to troubleshoot 
your simulation. See "Troubleshooting Modeler 
Tutorials".
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Viewing Results

Viewing Results

You can view results graphically in the Project Editor by 
selecting View Results from the Workspace pop-up 
menu.

After your simulation has executed, you will want to 
see the information collected for each statistic. There 
are several ways to view results; in this lesson you will 
use the View Results option in the Workspace pop-up 
menu.

You will learn different ways to view results in later 
lessons. 

To view the server Ethernet load for the simulation:

1 Right-click on the server node (node_31) choose 
View Results from the server’s Object pop-up 
menu.

➥ The node’s View Results dialog box opens.

2 Expand the Office network.node_31 > Ethernet 
hierarchy.

3 Click on the checkbox next to Load (bits/sec) to 
indicate that you want to view that result.
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Viewing Results

4 Click the Show button in the View Results dialog 
box.

➥ The graph of the server load appears in the 
Project Editor, as shown in the following figure.

The graph of the server load should resemble the 
following graph. Your results may differ slightly due to 
differences in node placement and link length, but the 
general trends should be consistent.

Server Load Graph

Simulation time, in 
minutes

bits/second. The 
unit of measure 
on this axis is 
shown in the 
statistic in the 
Choose Results 
dialog box
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Viewing Results

Note that at its peak, the load on the server is about 
6,000 bits/second. You will need this baseline for 
comparison after you add the second network.

When you finish viewing the server load graph, close 
this dialog box and the View Results dialog box. (If the 
system prompts you, choose to delete the graph 
panel.)

You also should look at the Global Ethernet Delay on 
the network. To view this statistic:

1 Right-click in the workspace, then select 
View Results from the pop-up menu.

2 Check the box next to Global Statistics > 
Ethernet > Delay (sec), then click the Show 
button to view the Ethernet delay for the whole 
network.
33



Viewing Results

Viewing Ethernet Delay for the Whole Network

➥ The Ethernet delay graph appears in the 
Project Editor. The graph should resemble the 
following figure.
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Viewing Results

Ethernet Delay Graph

Note that after the network reaches steady state the 
maximum delay is around 0.4 milliseconds.

When you finish viewing the graph, close the graph 
and the View Results dialog box.

Simulation time, in minutes

Seconds
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Expanding the Network

Expanding the Network

You have created a baseline network and gathered 
statistics about it. Now you are ready to expand the 
network and verify that it still operates sufficiently well 
with the additional load.

When performing a “what-if” comparison, it is 
convenient to store the baseline network as one 
scenario and create the experimental network as a 
different scenario. You will duplicate the existing 
scenario and make changes to it instead of building 
the new topology from the beginning. 

To duplicate a scenario:

1 Choose Scenarios > Duplicate Scenario...

2 Enter expansion as the name for the new 
scenario.

3 Click OK.

➥ The scenario, with all the nodes, links, 
statistics, and the simulation configuration, is 
duplicated and named expansion.
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Expanding the Network

The second-floor segment will resemble the first-floor 
segment, but will not have a server of its own. To build 
the new segment:

1 Select Topology > Rapid Configuration.

2 Choose Star for the topology and click OK...

3 Complete the Rapid Configuration dialog box with 
these values:

— Center Node Model: 
3C_SSII_1100_3300_4s_ae52_e48_ge3

— Periphery Node Model: Sm_Int_wkstn

— Number: 15

— Link model: 10BaseT

— X: 75, Y: 62.5, Radius: 20

Rapid Configuration Dialog Box
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Expanding the Network

4 Click OK to create the network.

Join the two networks:

1 If it is not already open, click the 
toolbar button to open the object 
palette.

2 Drag the Cisco 2514 router icon into the 
workspace between the two networks. Right-click 
to turn off node creation.

3 Click on the 10BaseT link icon in the object 
palette.

4 Create 10BaseT links between the Cisco router 
(node_50) and the 3Com switches at the center 
of each star.

5 Right-click to turn off link creation.

6 Close the object palette.

7 Select File > Save.
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Expanding the Network

The final network should look like this:

The Final Network

To run the expansion scenario:

1 Select DES > Configure/Run Discrete Event 
Simulation….

2 Verify that the Duration is set to 0.5 hours.
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Expanding the Network

3 Click the Run button to begin the simulation.

Simulation Sequence Dialog Box, Simulation Speed Tab Selected

➥ As before, a window appears showing the 
simulation’s progress. When the Simulation 
Speed tab is selected, an animated graph 
shows both the current and average speed in 
events per second.

4 When the simulation is done, close the Simulation 
Sequence dialog box. If you had problems, see 
"Troubleshooting Modeler Tutorials".
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Comparing Results

Comparing Results

To answer the questions posed about the addition of a 
second network to the existing LAN, you need to 
compare the results from both of the simulations you 
ran.

You will use the Compare Results menu item in the 
Object and Workspace pop-up menus to combine 
statistics from different scenarios in the same graph. 

To look at the server load from both scenarios at once:

1 Right-click on the server node (node_31) to bring 
up its Object pop-up menu.

2 Choose Compare Results (you can do this from 
either scenario in the project).

➥ A View Results dialog box appears containing 
a hierarchical representation of statistics 
collected for the server node.

If your results differ radically from those shown in the 
following figures, you will have to troubleshoot your 
simulation. See "Troubleshooting Modeler Tutorials".
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Comparing Results

When comparing results, choosing a statistic in one 
scenario produces a graph showing the value of that 
statistic in all scenarios. To view the results:

1 Select the Office Network.node_31 > Ethernet 
> Load (bits/sec) statistic and click the Show 
button. Your results should resemble those in the 
following figure (but may not be identical):

Server Load Compared

Simulation time, in minutes

bits/second
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Comparing Results

The following graph is the time average of the Ethernet 
load between the baseline (first_floor) scenario and 
the expansion scenario. You will learn how to create a 
graph of the time average in the next lesson. 

Time-averaged Server Load Compared

Note that while the average load for the expansion 
scenario is higher (as expected), the load as a whole 
appears to be leveling off (that is, not monotonically 
increasing), indicating a stable network.
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Comparing Results

The last step is to see how much the network’s delay is 
affected by adding a second floor. To compare 
Ethernet delay for the two scenarios:

1 Close the graph and the Compare Results dialog 
box for the server.

2 Right-click in the workspace, then select 
Compare Results from the Workspace pop-up 
menu.

3 Select the Global Statistics > Ethernet > 
Delay (sec) statistic.

4 Click Show to display the graph.

➥ The graph of the Global Ethernet Delay 
appears.

Your graph of Ethernet Delay should resemble the 
following:
44



Comparing Results

Ethernet Delay Compared

This graph shows that there is no significant 
change in Ethernet delay on the network. 
Although server load has increased, delay has 
not.

5 Close the open graph and the View Results 
dialog box.

6 Select File > Close and save changes before 
closing.

Simulation time, in minutes

Seconds
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Comparing Results

Now you are ready to go on to the M/M/1 Queue 
tutorial. This lesson explores the use of node models 
in the OPNET workflow. Return to the main tutorial 
menu and choose M/M/1 Queue from the list of 
available lessons. 
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