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Arquitectura de Redes Sistemas y Servicios: Práctica 7

Práctica 7 – Protocolos de acceso al medio: ALOHA y CSMA

“Sesión 2”

1- Objetivos

En esta segunda sesión analizaremos el protocolo CSMA y lo compararemos con ALOHA.
Además plantearemos un escenario donde evaluar las prestaciones del protocolo de acceso al medio
de Ethernet en un medio compartido.

2- Avisos generales

Si quieren conservar cualquier fichero entre sesiones guárdenlo en una memoria USB, dado que
no se asegura que los ficheros creados o modificados durante una sesión de prácticas se mantengan
para la siguiente.

3- ALOHA vs CSMA

OPNET dispone de un tutorial idóneo para el análisis de protocolos de acceso al medio, es el
denominado CSMA/CD. Se puede encontrar en el menú Help de la ventana principal de OPNET, . Al
seleccionar este menú, observaremos que aparecen entre otras opciones “Product Documentation” y
“Tutorials”. En la primera de ellas podremos encontrar información relativa al simulador, sobre cómo
utilizarlo, qué posibilidades ofrece, descriptores de los modelos que ya tiene predefinidos, etc... Se
trata de un pequeño manual al que acudir en momentos de duda. En la segunda, dispondremos de una
serie de tutoriales que permiten observar y llevar a cabo la puesta en práctica de algunos de los
aspectos explicados teóricamente en el apartado anterior.

Consulte la “lectura recomendada” en la práctica 1, le será de gran ayuda.

Como documentación adicional, dispone en la web de la asignatura, de un listado de funciones de
OPNET necesarias para la comprensión de determinadas secciones del tutorial. Abra el tutorial desde
la ventana de Opnet, menú Help > Tutorials y comience el tutorial CSMA/CD.

Nota: Realice el tutorial desde la página 53-70.

Errata tutorial CSMA/CD(OPNET 10.5): Página 55, punto 7 => ¡Correcto!

La errata radica en la figura de la página 54 en relación a este punto 7.

Analice en detalle cada uno de los pasos indicados por el tutorial con objeto de entender el por
qué de cada uno de ellos. Debería ser capaz de responder a las siguientes preguntas:

1. ¿Qué diferencias existen entre lo que se denomina stream wire y statistics wire en el editor de
nodo?

2. ¿Entre qué estados se aplica la condición PKT_ARVL&& FREE? ¿Qué significado tiene?

3. ¿Qué mejora ha necesitado añadir a su modelo de transmisor para que soporte CSMA?

4. En el modelo de proceso del transmisor CSMA, ¿Qué procedimiento se emplea para verificar
si el canal está libre? ¿En qué estado se encontrará dicho modelo si el canal resulta estar
ocupado?
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Checkpoint 7.4: Explica el diseño del transmisor de CSMA, tanto a nivel de nodo como de
proceso, relacionándolo con el comportamiento que ha de tener por utilizar CSMA como protocolo
de acceso al medio.

Checkpoint 7.5: Represente gráficamente el throughput del canal en función del tráfico,
considerando todas las simulaciones. ¿Cuál es la eficiencia de CSMA? ¿Coincide con la vista en
teoría? Indique cuál es el valor máximo del throughput. Razone su representación gráfica. Realice
una comparativa gráfica CSMA vs. ALOHA.

5. ¿Cuál de los dos protocolos presenta un mejor resultado en cuanto a eficiencia se refiere?
¿Cabía esperar que así fuera? ¿Por qué?

4- Evaluación de prestaciones del protocolo de acceso al medio de
Ethernet

Ethernet es un estándar de redes de computadoras de área local con acceso al medio por contienda
CSMA/CD o Carrier Sense Multiple Access with Collision Detection. CSMA es una técnica de
acceso a medio compartido que permite a los equipos escuchar el canal antes de transmitir para ver si
otro equipo lo está haciendo. Existen distintas variantes de este mecanismo, uno de ellos es
CSMA/CD.

CSMA/CD permite detectar no sólo si un equipo está transmitiendo, sino si ha habido colisión, de
manera que en base a esta información los equipos puedan variar su comportamiento. Existen tres
variantes:

 CSMA no-persistente: en caso de estar ocupado el canal, se espera un tiempo aleatorio y se
vuelve a escuchar, para transmitir inmediatamente si se encuentra libre.

 CSMA p-persistente: si el canal está ocupado se mantiene a la espera de que se libere para
transmitir. En caso de estar libre transmite con una probabilidad p y con (1-p) permanece a la
espera.

 CSMA 1-persistente: si el canal se encuentra ocupado se mantiene a la escucha del canal
hasta detectarlo libre y transmitir. Esto hace que puedan ocurrir colisiones siempre que haya
dos estaciones escuchando.

¿Qué protocolo de acceso al medio emplea Ethernet?

4.1 Crear el proyecto

Para crear un proyecto nuevo para la red de Ethernet:
1. Ejecutar OPNET Modeler 10.5 -- Educational Version => Seleccionar New del menú File.
2. Seleccionar Project => Clic OK => Nombre del proyecto <arssXY>_Ethernet, y el

escenario Coax => Clic OK.
3. En el Startup Wizard: En la ventana de diálogo Initial Topology, asegurarse de Create

Empty Scenario está seleccionado => Clic Next => Elegir Office de la lista Network Scale
=> Clic Next => Asignar 200 a X Span y mantener Y Span con 100 => Clic Next dos veces
=> Clic OK.
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4. Cerrar la ventana de diálogo Object Palette .
4.2 Crear la Red

Para crear la Red Ethernet coaxial:

1. Seleccionar Topology => Rapid Configuration. Elegir Bus y Clic OK.
2. Clic en el botón Select Models en la ventana de diálogo Rapid Configuration. Desde el menú

desplegable Model List elegir ethcoax y Clic OK.
3. En la ventana de diálogo Rapid Configuration, fijar los siguientes 8 valores y pulsar OK.

4. Para configurar el bus coaxial, Clic-derecho en el enlace horizontal => Seleccionar Advanced
Edit Attributes del menú:

a. Clic en el valor (value) del atributo model => Seleccionar Edit del menú desplegable =>
Elegir el modelo eth_coax_adv.

b. Asignar el valor 0,05 al atributo delay (retardo de propagación en seg/m).
c. Asignar 5 al atributo thickness.
d. Clic OK.
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5. Ya se ha creado la red. Compare con la figura siguiente. En caso de que se vea la red muy
pequeña o grande, se debe ajustar el zoom para seguir trabajando.

6. Salvar el proyecto.
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4.3 Configurar los nodos de la red

Configuración del tráfico generado por los nodos:

1. Clic-derecho en cualquiera de los 30 nodos => Select Similar Nodes. Ahora todos los nodos
de la red están seleccionados.

2. Clic-derecho en cualquiera de los 30 nodos => Edit Attributes.
3. Marcar la caja Apply Changes to Selected Objects para que se apliquen los cambios a todos

los nodos.
4. Expandir el árbol Traffic Generation Parameters:

a. Cambiar el valor ON State Time a exponential(100) => Cambiar el valor de OFF
State Time a exponential(0). (Nota: Los paquetes sólo se generan en el estado ON.)

5. Expandir el árbol Packet Generation Arguments:
a. Cambiar el valor del atributo Packet Size a constant(1024).
b. Clic-derecho en el atributo Interarrival Time y elegir Promote Attribute to Higher

Level. Esto nos permite asignar múltiples valores al atributo Interarrival Time y por
lo tanto probar las prestaciones de la red bajo diferentes modelos de carga
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6. Clic OK para volver al Editor de Proyectos. Si aparece una ventana avisándole que esa
configuración se añadirá a cada nodo, pulse en Yes.

7. Salvar el proyecto.

4.4 Configurar la simulación

Para examinar el desempeño de la red bajo cargas diferentes, necesita correr la simulación varias
veces cambiando la carga en la red. Hay una manera fácil de hacer eso. Recuerde que utilizamos el
atributo Interarrival Time (tiempo entre llegadas) para la generación de paquetes que los nodos
inyectan a la red. Dicho atributo se marcó como Promote Attribute to Higher Level. Aquí
asignaremos valores diferentes a ese atributo:

1. Clic en el botón Configure/Run Simulation:
2. Asegúrese de que está seleccionada la rama Common => Asignar 15 segundos a Duration.

3. Clic en la rama Object Attributes de Inputs.
4. Clic en el botón Add. La ventana de diálogo Add Attribute debe aparecer llena con los

atributos generados para todos los nodos de la red (si no viera los atributos en la lista, cierre el
proyecto y reábralo). Necesita añadir el atributo Interarrival Time para todos los nodos. Para
hacerlo:

a. Clic en el primer atributo de la lista (Office Network.node_0.Traffic Generation
….) => Clic en el botón Wildcard => Clic en node_0 y seleccione asterisco (*) del
menú desplegable => Clic OK.

b. Verá un nuevo atributo conteniendo el asterisco (el segundo de la lista). Para
configurarlo necesita hacer Clic en la celda bajo la columna Add?

c. La ventana de diálogo Add Attribute debe parecerse a la siguiente. Clic OK.
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5. Ahora debe ver Office Network.*.Traffic Generation Parameter … en la lista de atributos
de objetos de simulación. Clic en el atributo para seleccionarlo => Clic en el botón Set
Multiple Values en la ventana de diálogo.

6. Añadir los siguientes 9 valores. (Nota: Para añadir el primer valor, doble-Clic en la primera
celda de la columna Value => Teclee “exponential (2)” en la ventana de texto y pulse Enter.
Repetir esto para los 8 valores restantes: 1, 0.5, 0.25, 0.1, 0.05, 0.035, 0.03, 0.02. Se
recomienda empleen notación científica ya que el simulador no interpreta bien valores del
tipo 0, (cero coma) ó 0. (cero punto))

7. Clic OK. Ahora observe en la esquina superior derecha de la ventana de diálogo y asegúrese
que Number of runs es 9.
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8. Para cada una de las 9 ejecuciones de la simulación, necesitamos que el simulador salve un
valor “scalar” que representa la carga media “average” en la red y otro valor escalar que
representa la utilización media (throughput) de la red. Para salvar esos escalares necesitamos
configurar el simulador e indicarle dónde debe salvarlos. Clic en la rama Statistics Collection
de Outputs.

9. Asigne <arssXY>_Ethernet_Coax al campo de texto Scalar file.

10. Clic en Apply, y salve el proyecto (para ello necesitará pulsar Cancel).



Departamento de
Automática y Computación

Automatika eta
Konputazio Saila

Campus de Arrosadía
Arrosadiko Campusa
31006 Pamplona - Iruñea
Tfno. 948 169113, Fax. 948 168924
Email: ayc@unavarra.es

Arquitectura de Redes Sistemas y Servicios: Práctica 7

4.5 Seleccionar estadísticas

Para seleccionar las estadísticas a recoger de la simulación:
1. Clic-derecho en cualquier punto del área de trabajo (pero no en algún nodo o enlaces) y

seleccione Choose Individual Statistics del menú desplegable => Expanda el árbol Global
Statistics.

a. Expanda el árbol Traffic Sink => Clic en el check box próximo a Traffic Received
(packets/sec) (asegurese de seleccionar las estadísticas con unidades en packets/sec),

b. Expanda el árbol Traffic Source => Clic en el check box próximo a Traffic Sent
(packets/sec). Clic OK.

2. Ahora para recoger la media de las estadísticas anteriores como un valor escalar:
a. Seleccione Choose Statistics (Advanced) del menú Simulation.
b. Traffic Sent y Traffic Received deben aparecer bajo Global Statistic Probes.
c. Clic-derecho en Traffic Received => Edit Attributes. Poner el atributo scalar data a

enabled => Poner el atributo scalar type a time average => Comparar con la figura y
Clic OK.

d. Repetir los pasos anteriores con Traffic Sent .
e. Seleccione save del menú File en la ventana Probe Model y ciérrela.
f. Ha vuelto al editor de proyectos Project Editor. Asegúrese de salvar su proyecto.
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4.6 Ejecutar la simulación

Para ejecutar la simulación:

1. Clic en el botón Configure/Run Simulation =>
Asegúrese de que Duration marca 15 second(s) (no horas) => Clic Run. Dependiendo de la
potencia del ordenador esto puede tardar algunos minutos. En los ordenadores del laboratorio
apenas llevará unos segundos.

2. Ahora el ordenador está realizando las 9 ejecuciones, una por cada tasa de generación de
tráfico. Es normal que las ejecuciones tarden cada vez más porque la primera es la de menor
carga y se va incrementando hasta llegar a la última que simula un mayor tráfico.

3. Después de que el simulador termine las nueve ejecuciones, clic Close.
4. Salve su proyecto.

Si vuelve a repetir la simulación, OPNET añadirá los nuevos resultados a los resultados ya
existentes en el fichero escalar. Para evitar esta circunstancia borre el fichero escalar antes de
arrancar la nueva simulación.

 Ir al menú File => Seleccione Model Files => Delete Model Files => Seleccione ( .os):
Output Scalars => Selecione el fichero escalar a borrar;
(<arssXY>_Ethernet_Coax_Scalar) => Confirmar borrado con OK =>Clic Close.

4.7 Ver los resultados

Para ver y analizar los resultados:

1. Seleccione DES, Results, View Results (Advanced):. Ahora se abre la herramienta de
Analysis Configuration.

2. Recuerde que los resultados de la simulación los salvamos en un fichero escalar. Para cargar
ese fichero seleccione Load Output Scalar File del menú File => Seleccione
<arssXY>_Ethernet-Coax del menú desplegable.

3. Seleccione Create Scalar Panel del menú Panels => Asignar Traffic Source.Traffic Sent
(packets/sec).average a Horizontal => Asignar Traffic Sink.Traffic Received
(packets/sec).average a Vertical => Clic OK.

4. El gráfico resultante debe ser similar al de la figura siguiente:
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Checkpoint 7.6: Explicar el gráfico obtenido en la simulación que muestra la relación entre
paquetes recibidos (throughput) y enviados (carga). ¿Por qué el throughput es bajo cuando la carga es
muy baja o muy alta?


